bluez: Add 4.62 and update include to support new style checksums for the archive.
[openembedded.git] / recipes / librfid / librfid_svn.bb
1 DESCRIPTION = "RFID library"
2 SECTION = "devel"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "virtual/libusb0"
6 SRCNAME = "librfid"
7
8 SRCREV = "2094"
9 PV = "0.2.0+svnr${SRCPV}"
10 PR = "r5"
11
12 SRC_URI = "svn://svn.gnumonks.org/trunk;module=${SRCNAME};proto=http \
13            file://010-rc632-definitions-fix.patch;patch=1 \
14            file://011-rc632-define-fixes-followups.patch;patch=1 \
15            file://012-rc632-error-reg-ro-2.patch;patch=1 \
16            file://013-zero-UID.patch;patch=1 \
17            file://015-no_segfault.patch;patch=1 \
18            file://soos01-set_clear_bits.patch;patch=1 \
19            file://soos02-check-errors.patch;patch=1 \
20            file://soos03-no_hang-openpcd.patch;patch=1 \
21            file://librfid.rules \
22           "
23
24 SRC_URI_append_boc01 = "file://spidev.patch;patch=1"
25 PACKAGE_ARCH_boc01 = "boc01"
26 EXTRA_OECONF_boc01 += "--enable-spidev"
27
28 S = "${WORKDIR}/${SRCNAME}"
29
30 inherit autotools
31
32 do_install_append() {
33         install -d ${D}/${sysconfdir}/udev/rules.d
34         install -m 0644 ${WORKDIR}/librfid.rules ${D}/${sysconfdir}/udev/rules.d/70-librfid.rules
35 }
36
37 do_stage() {
38         autotools_stage_all
39 }