sg3-utils: add newer buildable version
[openembedded.git] / recipes / libnids / libnids_1.18.bb
1 DESCRIPTION = "Libnids performs assembly of TCP segments \
2 into TCP streams, IP defragmentation, and TCP port \
3 scan detection."
4 LICENSE = "GPL"
5 SECTION = "libs"
6 DEPENDS = "libnet-1.0 libpcap"
7 PR = "r1"
8
9 SRC_URI = "\
10   ${SOURCEFORGE_MIRROR}/libnids/libnids-${PV}.tar.gz \
11   file://configure.patch;patch=1"
12
13 inherit autotools
14
15 EXTRA_OECONF = "\
16   --with-libpcap=${STAGING_LIBDIR}/.. \
17   --with-libnet=${STAGING_LIBDIR}/.. \
18 "
19 EXTRA_OEMAKE = "'install_prefix=${D}'"
20
21 do_stage () {
22         install -m 0644 ${S}/src/nids.h ${STAGING_INCDIR}/
23         oe_libinstall -a -C src libnids ${STAGING_LIBDIR}
24 }