abiword: add 2.8.3
[openembedded.git] / recipes / libmikmod / libmikmod_3.2.0-beta2.bb
1 DESCRIPTION = "libmikmod is a module player library supporting many formats, including mod, s3m, it, and xm."
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5
6 PR="r1"
7
8 DEFAULT_PREFERENCE = "-1"
9
10 TARGET_CC_ARCH += "${LDFLAGS}"
11
12 SRC_URI = "\
13   http://mikmod.raphnet.net/files/libmikmod-${PV}.tar.gz \
14   file://m4.patch;patch=1 \
15   file://autofoo.patch;patch=1 \
16 "
17
18 inherit autotools binconfig
19
20 EXTRA_OECONF = "\
21   --disable-af \
22   --enable-alsa \
23   --disable-esd \
24   --enable-oss \
25   --disable-sam9407 \
26   --disable-ultra \
27   --disable-esdtest \
28   --enable-threads \
29 "
30
31 do_stage() {
32         oe_libinstall -a -so -C libmikmod libmikmod ${STAGING_LIBDIR}
33         install -m 0644 ${S}/include/mikmod.h ${STAGING_INCDIR}/
34         install -d ${STAGING_DATADIR}/aclocal/
35         install -m 0644 libmikmod.m4 ${STAGING_DATADIR}/aclocal/
36 }