sg3-utils: add newer buildable version
[openembedded.git] / recipes / input-utils / input-utils_1.0.bb
1 DESCRIPTION = "Utilities for the Linux input drivers"
2 HOMEPAGE = "http://packages.tanglu.org/source/aequorea/input-utils"
3
4 LICENSE = "GPLv2"
5 LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
6
7 PV = "1.0"
8 PR = "r0"
9
10 SRC_URI = "http://ftp.de.debian.org/debian/pool/main/i/input-utils/input-utils_1.0.orig.tar.gz \
11            file://no-e.patch;patch=1"
12 SRC_URI_append_arm = " file://0001-autoconf-fix-for-cross-compilation-for-ARM.patch;patch=1"
13
14 SRC_URI[md5sum] = "3e58772e8647093b1de2f2c90bfb9ee8"
15 SRC_URI[sha256sum] = "ab6f550f01bb5fcede492ab88711d82bacee4229cf2f5dc55a349b3bff4e3b13"
16
17 S = "${WORKDIR}/input-1.0"
18
19 do_compile () {
20     oe_runmake
21 }
22
23 # set the DESTDIR and the STRIP variables used by the GNUmakefile.
24 # The STRIP variable is set to blank or else the variable setting from OE
25 # is picked up as <TC>-strip and the install step sees that as another
26 # file to install.
27 EXTRA_OEMAKE = "DESTDIR=${D} STRIP=''"
28
29 do_install () {
30     oe_runmake install
31 }