xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / hugs / hugs_hugs98-Nov2003.bb
1 DEPENDS = "readline"
2 SRC_URI = "http://cvs.haskell.org/Hugs/downloads/Nov2003/${PV}.tar.gz \
3            file://hugs.desktop \
4            file://hugs.png"
5 LICENSE = "BSD"
6 PR = "r2"
7
8 S = "${WORKDIR}/${PV}/src/unix"
9
10 inherit autotools
11
12 # disable STRIP as the generated Makefile falsely call arm-linux-strip
13 # on compiling which leads to abortion of the compile
14 # we strip manually anyway so disabling it here is 'ok'
15 EXTRA_OECONF = "--disable-ffi STRIP=true"
16
17 do_configure() {
18     oe_runconf
19 }
20
21 do_compile() {
22     cd ../ && oe_runmake
23 }
24
25 do_install() {
26     cd ../ && autotools_do_install
27     install -d ${D}${datadir}/applications/
28     install -m 0644 ${WORKDIR}/hugs.desktop ${D}${datadir}/applications/
29     install -d ${D}${datadir}/pixmaps/
30     install -m 0644 ${WORKDIR}/hugs.png ${D}${datadir}/pixmaps/
31 }