netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / gstreamer / gst-ffmpeg_0.10.10.bb
1 DESCRIPTION = "FFmpeg-based GStreamer plug-in"
2 SECTION = "multimedia"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 HOMEPAGE = "http://www.gstreamer.net/"
6 DEPENDS = "ffmpeg gstreamer gst-plugins-base zlib"
7
8 inherit autotools pkgconfig
9
10 SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2;name=archive \
11            file://lower-rank.diff;patch=1 \
12 "
13 SRC_URI[archive.md5sum] = "447292deff5f3748444e6a5fba41da29"
14 SRC_URI[archive.sha256sum] = "697114483444a0a469028857a1d58145c99e6f5d2cd7edd8cb04cdc3fc72ad94"
15
16 FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
17 FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
18 FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
19
20 EXTRA_OECONF = " --with-system-ffmpeg "
21
22 # We do this because the install program is called with -s which causes it to
23 # call "strip" and it then mangles cross compiled stuff..
24 PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
25
26 # Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
27 CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
28