1 # FIXME, consider using kernel staging directory instead of KERNEL_SOURCE which is
2 # located in the work directory. see module.bbclass
4 DESCRIPTION = "gpio-event driver and userspace program"
8 RDEPENDS = "kernel (${KERNEL_VERSION})"
9 DEPENDS = "virtual/kernel"
13 SRC_URI = "http://davehylands.com/gumstix-wiki/gpio-event/gpio-event-2.6.21-1444-select.tar.gz \
14 file://makefile.patch;patch=1 \
17 S = "${WORKDIR}/gpio-event"
21 addtask builddir after do_fetch before do_unpack
22 addtask movesrc after do_unpack before do_patch
24 EXTRA_OEMAKE = 'CROSS_COMPILE="${CROSS_COMPILE}" \
25 KERNELDIR="${KERNEL_SOURCE}" \
37 mv gpio-event*.c gpio-event*.h Makefile ${S}
41 echo "Nothing to configure for gpio-event"
45 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
51 # install programs to bindir
52 install -m 0755 -d ${D}${bindir}
53 install -m 0755 ${S}/gpio-event ${D}${bindir}
55 # kernel module installs with other modules
56 install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
57 # use cp instead of install so the driver doesn't get stripped
58 cp ${S}/gpio-event-drv.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
62 FILES_${PN} = "${bindir}/gpio-event"
63 FILES_${PN} += "${base_libdir}/modules/${KERNEL_VERSION}/extra/gpio-event-drv.ko"