netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / gpio-event / gpio-event.bb
1 # FIXME, consider using kernel staging directory instead of KERNEL_SOURCE which is
2 # located in the work directory. see module.bbclass
3
4 DESCRIPTION = "gpio-event driver and userspace program"
5 PRIORITY = "optional"
6 SECTION = "base"
7 LICENSE = "GPL"
8 RDEPENDS = "kernel (${KERNEL_VERSION})"
9 DEPENDS = "virtual/kernel"
10
11 PR = "r4"
12
13 SRC_URI = "http://davehylands.com/gumstix-wiki/gpio-event/gpio-event-2.6.21-1444-select.tar.gz \
14    file://makefile.patch;patch=1 \
15    "
16
17 S = "${WORKDIR}/gpio-event"
18
19 inherit module-base
20
21 addtask builddir after do_fetch before do_unpack
22 addtask movesrc after do_unpack before do_patch
23
24 EXTRA_OEMAKE = 'CROSS_COMPILE="${CROSS_COMPILE}" \
25                 KERNELDIR="${KERNEL_SOURCE}" \
26                 CC="${CC}" \
27                 '
28
29 PARALLEL_MAKE = ""
30
31 do_builddir () {
32    mkdir -p ${S}
33 }
34
35 do_movesrc () {
36    cd ${WORKDIR}
37    mv gpio-event*.c gpio-event*.h Makefile ${S}
38 }
39
40 do_configure () {
41         echo "Nothing to configure for gpio-event"
42 }
43
44 do_compile () {
45    unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
46    cd ${S}
47         oe_runmake   
48 }
49
50 do_install () {
51    # install programs to bindir
52    install -m 0755 -d ${D}${bindir}
53         install -m 0755  ${S}/gpio-event ${D}${bindir}
54
55    # kernel module installs with other modules
56    install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
57    # use cp instead of install so the driver doesn't get stripped
58    cp ${S}/gpio-event-drv.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
59 }
60
61 PACKAGES = "${PN}"
62 FILES_${PN} = "${bindir}/gpio-event"
63 FILES_${PN} += "${base_libdir}/modules/${KERNEL_VERSION}/extra/gpio-event-drv.ko"
64