u-boot-omap3pandora: Bump SRCREV to version with UBI enabled.
[openembedded.git] / recipes / gpe-bootsplash / gpe-bootsplash_1.15.bb
1 inherit gpe
2
3 DEPENDS = "gtk+ libsvg-cairo"
4 SECTION = "gpe"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 PR = "r10"
8
9 SRC_URI += "file://splash-p.svg \
10             file://splash-l.svg \
11             file://init.patch;patch=1 \
12             file://no-strip-on-install.patch;patch=1"
13
14
15 FILES_${PN} += "${datadir}/gpe"
16
17 do_install_append() {
18         install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-gpe-portrait.svg
19         install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-gpe-landscape.svg
20         mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
21 }
22
23 pkg_postinst() {
24
25         update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg 10
26         update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg 10
27 }
28
29 pkg_postrm() {
30         update-alternatives --remove bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg
31         update-alternatives --remove bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg
32 }