abiword: add 2.8.3
[openembedded.git] / recipes / gpe-bootsplash / gpe-bootsplash-theme-e.bb
1 DESCRIPTION = "An Enlightenment theme for gpe-bootsplash"
2 SECTION = "base"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "gpe-bootsplash"
6 RDEPENDS = "gpe-bootsplash"
7 PR = "r1"
8
9 export THEME = "e"
10
11 SRC_URI = "file://splash-e-portrait.svg \
12            file://splash-e-landscape.svg"
13
14 #FIXME: Please use $datadir instead of /usr/share
15 #FIXME: please use an gpe-bootsplash-theme.inc to reduce duplication
16
17 do_install() {
18         install -d "${D}/usr/share/gpe"
19         install -m 0644 ${WORKDIR}/splash-${THEME}* ${D}/usr/share/gpe
20 }
21
22 pkg_postinst() {
23         update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg 20
24         update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg 20
25 }
26
27 pkg_postrm() {
28         update-alternatives --remove bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg
29         update-alternatives --remove bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg
30 }
31
32 FILES_${PN} = "/usr/share/gpe/splash-${THEME}-*"