ncurses: add xterm terminfo file back
[openembedded.git] / recipes / gnome-mplayer / gecko-mediaplayer_svn.bb
1 DESCRIPTION = "Gecko plugin for gnome-mplayer"
2 HOMEPAGE = "http://dekorte.homeip.net/download/gecko-mediaplayer/"
3 LICENSE = "GPL"
4 DEPENDS = "firefox gtk+ gconf dbus-glib"
5 RDEPENDS = "firefox gnome-mplayer"
6
7 PV = "0.9.9.2+${SRCPV}"
8 SRCREV = "385"
9
10 inherit autotools
11
12 SRC_URI = "svn://gecko-mediaplayer.googlecode.com/svn/;module=trunk;proto=http \
13            file://extensions \
14 "
15
16 S = "${WORKDIR}/trunk"
17
18 # XUL changed API badly, so we need to choose between pre 3.6 and post 3.6 firefox :(
19 EXTRA_OECONF = " --enable-new-libxul=yes "
20 TARGET_CC_ARCH += " -DHAVE_NEW_XULRUNNER=1 "
21
22 do_install_append() {
23         cp -dpR ${WORKDIR}/extens* ${D}${libdir}/mozilla/
24 }
25
26 PACKAGES =+ "${PN}-firefox-hack"
27 RDEPENDS_${PN}-firefox-hack = "${PN}"
28 FILES_${PN}-firefox-hack = "${libdir}/mozilla/extensions"
29
30 FILES_${PN} += "${sysconfdir}/* \
31                 ${libdir}/mozilla/*"
32 FILES_${PN}-dbg += "${libdir}/mozilla*/plugins/.debug/*"
33
34 pkg_postinst_${PN}-firefox-hack() {
35 for firefoxdir in $D${libdir}/firefox-* ; do
36         if [ -e $firefoxdir/extensions/ ] ; then 
37                 ln -sf ${libdir}/mozilla/extensions/flash@alwaysinnovating.com $firefoxdir/extensions/
38         fi
39 done
40 }
41