u-boot-omap3pandora: Bump SRCREV to version with UBI enabled.
[openembedded.git] / recipes / gnome / gnome-games_2.24.3.bb
1 DESCRIPTION = "GNOME Games"
2 HOMEPAGE = "http://live.gnome.org/GnomeGames/"
3 SECTION = "x11/gnome"
4 LICENSE = "GPL"
5 DEPENDS = " guile libggz ggz-client-libs python-pygtk gtk+ libgnome libgnomeui librsvg gnome-vfs gconf libglade gnome-common gnome-python-desktop gnome-python gstreamer virtual/libsdl libsdl-mixer"
6
7 inherit gnome distutils-base gconf
8
9 PR = "r2"
10
11 SRC_URI += "file://ggz-unbreak-m4.patch;patch=1 \
12            "
13
14 EXTRA_OECONF = "--with-libggz-includes=${STAGING_INCDIR} \
15                 --with-libggz-libraries=${STAGING_LIBDIR} \
16                 --with-ggzmod-includes=${STAGING_INCDIR} \
17                 --with-ggzmod-libraries=${STAGING_LIBDIR} \
18                 --enable-scalable \
19                 INTLTOOL_PERL=${STAGING_BINDIR_NATIVE}/perl \
20                "
21
22 # disable help dir and crappy old sdl-macro
23 do_configure_prepend() {
24         if [ -e m4/sdl.m4 ]; then
25            rm m4/sdl.m4
26         fi
27         for i in $(find ${S} -name "Makefile.am") ; do
28                 sed -i -e s:help::g $i
29         done
30 }
31
32 # copy matchbox icons
33 do_install_append() {
34         install -m 0644 ${D}/${datadir}/icons/hicolor/48x48/apps/* ${D}/${datadir}/pixmaps
35 }
36
37 LDFLAGS += "-lguile -lgmp -lcrypt -lm -lltdl"
38
39 FILES_${PN}-doc += " ${datadir}/gnome/help"
40 FILES_${PN}-dbg += " ${bindir}/.debug ${libdir}/gnome-games/.debug"
41
42 ALLOW_EMPTY_${PN} = "1"
43 RDEPENDS_${PN} += "gnome-games-aisleriot gnome-games-blackjack gnome-games-cards gnome-games-glchess gnome-games-glines gnome-games-gnect gnome-games-gnibbles gnome-games-gnobots2 gnome-games-gnometris gnome-games-gnomine gnome-games-gnotravex gnome-games-gnotski gnome-games-gtali gnome-games-iagno gnome-games-mahjongg gnome-games-same-gnome gnome-games-sudoku "
44
45 PACKAGES =+ "gnome-games-common"
46 DESCRIPTION_gnome-games-common = "GNOME games common resources"
47 FILES_gnome-games-common = "${datadir}/ggz \
48                                 ${libdir}/ggz \
49                                 ${sysconfdir} \
50                                 ${datadir}/gnome-games/icons \
51                                 ${datadir}/icons \
52                                 ${datadir}/gnome-games/sounds"
53 # svg is needed for --enable-scalable by nearly all, so put into -common
54 RDEPENDS_gnome-games-common = "librsvg librsvg-gtk"
55
56 PACKAGES =+ "gnome-games-cards"
57 DESCRIPTION_gnome-games-cards = "GNOME games playing card resources"
58 FILES_gnome-games-cards = "${datadir}/gnome-games/pixmaps \
59                                 ${libdir}/gnome-games/gnome-games-render-cards \
60                                 ${datadir}/gnome-games-common/cards"
61
62 PACKAGES =+ "gnome-games-gnometris"
63 DESCRIPTION_gnome-games-gnometris = "GNOME tetris game"
64 RDEPENDS_gnome-games-gnometris = "gnome-games-common"
65 FILES_gnome-games-gnometris = "${bindir}/gnometris \
66                                 ${datadir}/pixmaps/gnometris \
67                                 ${datadir}/pixmaps/gnome-gnometris.png \
68                                 ${datadir}/applications/gnometris.desktop \
69                                 ${sysconfdir}/gconf/schemas/gnometris.schemas \
70                                 /var/games/gnometris.scores"
71
72 PACKAGES =+ "gnome-games-gnomine"
73 DESCRIPTION_gnome-games-gnomine = "GNOME minesweeper game"
74 RDEPENDS_gnome-games-gnomine = "gnome-games-common"
75 FILES_gnome-games-gnomine = "${bindir}/gnomine \
76                                 ${datadir}/pixmaps/gnomine \
77                                 ${datadir}/pixmaps/gnome-mines.png \
78                                 ${datadir}/applications/gnomine.desktop \
79                                 ${sysconfdir}/gconf/schemas/gnomine.schemas \
80                                 /var/games/gnomine.*.scores"
81
82 PACKAGES =+ "gnome-games-aisleriot"
83 DESCRIPTION_gnome-games-aisleriot = "GNOME solitaire games"
84 RDEPENDS_gnome-games-aisleriot = "gnome-games-common gnome-games-cards"
85 FILES_gnome-games-aisleriot = "${bindir}/sol \
86                                 ${datadir}/gnome-games/aisleriot \
87                                 ${datadir}/pixmaps/gnome-aisleriot.png \
88                                 ${datadir}/pixmaps/gnome-freecell.png \
89                                 ${datadir}/applications/sol.desktop \
90                                 ${datadir}/applications/freecell.desktop \
91                                 ${sysconfdir}/gconf/schemas/aisleriot.schemas"
92
93 PACKAGES =+ "gnome-games-blackjack"
94 DESCRIPTION_gnome-games-blackjack = "GNOME blackjack game"
95 RDEPENDS_gnome-games-blackjack = "gnome-games-common gnome-games-cards"
96 FILES_gnome-games-blackjack = "${bindir}/blackjack \
97                                 ${datadir}/gnome-games/blackjack \
98                                 ${datadir}/pixmaps/gnome-blackjack.png \
99                                 ${datadir}/applications/blackjack.desktop \
100                                 ${sysconfdir}/gconf/schemas/blackjack.schemas"
101
102 PACKAGES =+ "gnome-games-gnect"
103 DESCRIPTION_gnome-games-gnect = "GNOME four-in-a-row game"
104 RDEPENDS_gnome-games-gnect = "gnome-games-common"
105 FILES_gnome-games-gnect = "${bindir}/gnect \
106                                 ${datadir}/gnect \
107                                 ${datadir}/pixmaps/gnect \
108                                 ${datadir}/pixmaps/gnome-gnect.png \
109                                 ${datadir}/applications/gnect.desktop \
110                                 ${sysconfdir}/gconf/schemas/gnect.schemas"
111
112 PACKAGES =+ "gnome-games-same-gnome"
113 DESCRIPTION_gnome-games-same-gnome = "GNOME block removal game"
114 RDEPENDS_gnome-games-same-gnome = "gnome-games-common"
115 FILES_gnome-games-same-gnome = "${bindir}/same-gnome \
116                                 ${datadir}/gnome-games/same-gnome/themes/2.10 \
117                                 ${datadir}/pixmaps/gnome-samegnome.png \
118                                 ${datadir}/applications/same-gnome.desktop \
119                                 ${sysconfdir}/gconf/schemas/same-gnome.schemas \
120                                 /var/games/same-gnome.*.scores"
121
122 PACKAGES =+ "gnome-games-mahjongg"
123 DESCRIPTION_gnome-games-mahjongg = "GNOME mahjongg game"
124 RDEPENDS_gnome-games-mahjongg = "gnome-games-common"
125 FILES_gnome-games-mahjongg = "${bindir}/mahjongg \
126                                 ${datadir}/gnome-games/mahjongg \
127                                 ${datadir}/pixmaps/mahjongg \
128                                 ${datadir}/pixmaps/gnome-mahjongg.png \
129                                 ${datadir}/applications/mahjongg.desktop \
130                                 ${sysconfdir}/gconf/schemas/mahjongg.schemas \
131                                 /var/games/mahjongg.*.scores"
132
133 PACKAGES =+ "gnome-games-gtali"
134 DESCRIPTION_gnome-games-gtali = "GNOME yahtzee game"
135 RDEPENDS_gnome-games-gtali = "gnome-games-common"
136 FILES_gnome-games-gtali = "${bindir}/gtali \
137                                 ${datadir}/pixmaps/gtali \
138                                 ${datadir}/pixmaps/gnome-tali.png \
139                                 ${datadir}/applications/gtali.desktop \
140                                 ${sysconfdir}/gconf/schemas/gtali.schemas \
141                                 /var/games/gtali.*.scores"
142
143 PACKAGES =+ "gnome-games-gnotravex"
144 DESCRIPTION_gnome-games-gnotravex = "GNOME tile matching game"
145 RDEPENDS_gnome-games-gnotravex = "gnome-games-common"
146 FILES_gnome-games-gnotravex = "${bindir}/gnotravex \
147                                 ${datadir}/pixmaps/gnotravex \
148                                 ${datadir}/pixmaps/gnome-tetravex.png \
149                                 ${datadir}/applications/gnotravex.desktop \
150                                 ${sysconfdir}/gconf/schemas/gnotravex.schemas \
151                                 /var/games/gnotravex.*.scores"
152
153 PACKAGES =+ "gnome-games-gnotski"
154 DESCRIPTION_gnome-games-gnotski = "GNOME blocks puzzle game"
155 RDEPENDS_gnome-games-gnotski = "gnome-games-common"
156 FILES_gnome-games-gnotski = "${bindir}/gnotski \
157                                 ${datadir}/gnome-games/gnotski \
158                                 ${datadir}/pixmaps/gnome-klotski.png \
159                                 ${datadir}/applications/gnotski.desktop \
160                                 ${sysconfdir}/gconf/schemas/gnotski.schemas \
161                                 /var/games/gnotski.*.scores"
162
163 PACKAGES =+ "gnome-games-glines"
164 DESCRIPTION_gnome-games-glines = "GNOME five-or-more game"
165 RDEPENDS_gnome-games-glines = "gnome-games-common"
166 FILES_gnome-games-glines = "${bindir}/glines \
167                                 ${datadir}/pixmaps/glines \
168                                 ${datadir}/pixmaps/gnome-glines.png \
169                                 ${datadir}/applications/glines.desktop \
170                                 ${sysconfdir}/gconf/schemas/glines.schemas \
171                                 /var/games/glines.*.scores"
172
173 PACKAGES =+ "gnome-games-iagno"
174 DESCRIPTION_gnome-games-iagno = "GNOME reversi game"
175 RDEPENDS_gnome-games-iagno = "gnome-games-common"
176 FILES_gnome-games-iagno = "${bindir}/iagno \
177                                 ${datadir}/pixmaps/iagno \
178                                 ${datadir}/pixmaps/gnome-iagno.png \
179                                 ${datadir}/applications/iagno.desktop \
180                                 ${sysconfdir}/gconf/schemas/iagno.schemas"
181
182 PACKAGES =+ "gnome-games-gnobots2"
183 DESCRIPTION_gnome-games-gnobots2 = "GNOME robots game"
184 RDEPENDS_gnome-games-gnobots2 = "gnome-games-common"
185 FILES_gnome-games-gnobots2 = "${bindir}/gnobots2 \
186                                 ${datadir}/pixmaps/gnobots2 \
187                                 ${datadir}/gnobots2 \
188                                 ${datadir}/pixmaps/gnome-robots.png \
189                                 ${datadir}/applications/gnobots2.desktop \
190                                 ${sysconfdir}/gconf/schemas/gnobots2.schemas \
191                                 /var/games/gnobots2.*.scores"
192
193 PACKAGES =+ "gnome-games-gnibbles"
194 DESCRIPTION_gnome-games-gnibbles = "GNOME worm game"
195 RDEPENDS_gnome-games-gnibbles = "gnome-games-common"
196 FILES_gnome-games-gnibbles = "${bindir}/gnibbles \
197                                 ${datadir}/pixmaps/gnibbles \
198                                 ${datadir}/gnibbles \
199                                 ${datadir}/pixmaps/gnome-gnibbles.png \
200                                 ${datadir}/applications/gnibbles.desktop \
201                                 ${sysconfdir}/gconf/schemas/gnibbles.schemas \
202                                 /var/games/gnibbles.*.scores"
203
204 PACKAGES =+ "gnome-games-glchess"
205 DESCRIPTION_gnome-games-glchess = "GNOME chess"
206 RDEPENDS_gnome-games-glchess = "python-pygtk python-codecs \
207                                 python-netclient python-xml \
208                                 gnome-python"
209 FILES_gnome-games-glchess = "${bindir}/glchess \
210                                 ${bindir}/gnome-gnuchess \
211                                 ${datadir}/pixmaps/glchess \
212                                 ${datadir}/glchess \
213                                 ${datadir}/pixmaps/gnome-glchess.png \
214                                 ${datadir}/applications/glchess.desktop \
215                                 ${sysconfdir}/gconf/schemas/glchess.schemas \
216                                 ${PYTHON_SITEPACKAGES_DIR}/glchess"
217
218 PACKAGES =+ "gnome-games-sudoku"
219 DESCRIPTION_gnome-games-sudoku = "GNOME sudoku"
220 RDEPENDS_gnome-games-sudoku = "python-pygtk python-codecs python-difflib \
221                                 python-xml python-netclient \
222                                 python-textutils python-threading \
223                                 gnome-python gnome-python-desktop"
224 FILES_gnome-games-sudoku = "${bindir}/gnome-sudoku \
225                                 ${datadir}/pixmaps/gnome-sudoku \
226                                 ${datadir}/gnome-sudoku \
227                                 ${datadir}/pixmaps/gnome-sudoku.png \
228                                 ${datadir}/applications/gnome-sudoku.desktop \
229                                 ${PYTHON_SITEPACKAGES_DIR}/gnome_sudoku"