u-boot-omap3pandora: Bump SRCREV to version with UBI enabled.
[openembedded.git] / recipes / gnome / gconf-dbus_svn.bb
1 DESCRIPTION = "The GNOME Settings daemon using DBUS for communication."
2 DEPENDS = "intltool-native virtual/libintl glib-2.0 dbus dbus-glib libxml2 popt gtk-doc-native"
3 LICENSE = "GPL"
4 SECTION = "x11/utils"
5 PROVIDES = "gconf"
6 RPROVIDES_${PN} = "gconf"
7 RPROVIDES_${PN}-dev = "gconf-dev"
8
9 SRCREV = "641"
10 PV = "2.16.0+svnr${SRCPV}"
11 PR = "r0"
12
13 inherit autotools pkgconfig
14
15 SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \
16         file://69gconfd-dbus"
17 S = "${WORKDIR}/trunk"
18
19 PARALLEL_MAKE = ""
20
21 EXTRA_OECONF = "--with-ipc=dbus --disable-gtk-doc --disable-gtk --enable-shared --disable-static"
22
23 do_configure_prepend() {
24         touch gtk-doc.make
25 }
26
27 do_stage() {
28         autotools_stage_all
29         install -m 0644 gconf-2.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
30 }
31
32 do_install_append() {
33         install -d ${D}/${sysconfdir}/X11/Xsession.d
34         install -m 755 ${WORKDIR}/69gconfd-dbus ${D}/${sysconfdir}/X11/Xsession.d/
35 }
36
37 FILES_${PN} = "${libdir}/GConf-dbus/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus* ${libdir}/*.so.* ${bindir}/* ${libexecdir}/*"
38 FILES_${PN}-dbg += " ${libdir}/GConf-dbus/2/.debug"
39 FILES_${PN}-dev += "${libdir}/GConf-dbus/2/*.la ${datadir}/sgml/gconf/gconf-1.0.dtd"
40