netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / glibc / glibc_2.3.5+cvs20050627.bb
1 require glibc.inc
2
3 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs-2.3.5"
4 SRCDATE = "20050627"
5 PR = "${INC_PR}.0"
6
7 #Doesnt build for sh3
8 DEFAULT_PREFERENCE_sh3="-1"
9
10 GLIBC_ADDONS ?= "ports,linuxthreads"
11
12 GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN"
13
14 #
15 # For now, we will skip building of a gcc package if it is a uclibc one
16 # and our build is not a uclibc one, and we skip a glibc one if our build
17 # is a uclibc build.
18 #
19 # See the note in gcc/gcc_3.4.0.oe
20 #
21
22 python __anonymous () {
23     import bb, re
24     uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
25     if uc_os:
26         raise bb.parse.SkipPackage("incompatible with target %s" %
27                                    bb.data.getVar('TARGET_OS', d, 1))
28 }
29
30 RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
31 RPROVIDES_${PN}-dev += "libc-dev virtual-libc-dev"
32
33 #          file://noinfo.patch;patch=1
34 #          file://ldconfig.patch;patch=1;pnum=0
35 #          file://arm-machine-gmon.patch;patch=1;pnum=0 \
36 #          \
37 #          file://arm-ioperm.patch;patch=1;pnum=0 \
38 #          file://ldd.patch;patch=1;pnum=0 \
39 SRC_URI = "http://familiar.handhelds.org/source/v0.8.3/stash_libc_sources.redhat.com__20050627.tar.gz \
40            http://familiar.handhelds.org/source/v0.8.3/stash_ports_sources.redhat.com__20050627.tar.gz \
41            file://arm-audit.patch;patch=1 \
42            file://arm-audit2.patch;patch=1 \
43            file://arm-no-hwcap.patch;patch=1 \
44            file://arm-memcpy.patch;patch=1 \
45            file://arm-longlong.patch;patch=1;pnum=0 \
46            file://fhs-linux-paths.patch;patch=1 \
47            file://dl-cache-libcmp.patch;patch=1 \
48            file://ldsocache-varrun.patch;patch=1 \
49            file://5090_all_stubs-rule-fix.patch;patch=1 \
50            file://raise.patch;patch=1 \
51            file://zecke-sane-readelf.patch;patch=1 \
52            file://glibc-2.3.5-fix-weak-alias-arm.patch;patch=1 \
53            file://glibc-2.3.5-fix-weak-alias-arm-2.patch;patch=1 \
54            file://etc/ld.so.conf \
55            file://generate-supported.mk"
56
57 # seems to fail on tls platforms
58 SRC_URI_append_arm = " file://dyn-ldconfig-20041128.patch;patch=1"
59 SRC_URI_append_armeb = " file://dyn-ldconfig-20041128.patch;patch=1"
60
61 # Build fails on sh3 and sh4 without additional patches
62 SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1 \
63                        file://superh-fcntl.patch;patch=1;pnum=0"
64 SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1 \
65                        file://superh-fcntl.patch;patch=1;pnum=0"
66
67 S = "${WORKDIR}/libc"
68 B = "${WORKDIR}/build-${TARGET_SYS}"
69
70 RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
71 RPROVIDES_${PN}-dev += "libc-dev virtual-libc-dev"
72
73 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
74                 --without-cvs --disable-profile --disable-debug --without-gd \
75                 --enable-clocale=gnu \
76                 --enable-add-ons=${GLIBC_ADDONS} \
77                 --with-headers=${STAGING_INCDIR} \
78                 --without-selinux \
79                 ${GLIBC_EXTRA_OECONF}"
80
81 EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}"
82
83 #avoid too much optimization on ppc
84 CFLAGS_dht-walnut += " -O1 -g0 -fPIC -fno-inline-functions -fno-unit-at-a-time "
85
86 do_munge() {
87         # Integrate ports into tree
88         mv ${WORKDIR}/ports ${S}
89
90         # http://www.handhelds.org/hypermail/oe/51/5135.html
91         # Some files were moved around between directories on
92         # 2005-12-21, which means that any attempt to check out
93         # from CVS using a datestamp older than that will be doomed.
94         #
95         # This is a workaround for that problem.
96         rm -rf ${S}/bits
97 }
98
99 addtask munge before do_patch after do_unpack
100
101 export default_mmap_threshold_familiar = "32*1024"
102
103 do_configure () {
104         if [ "x$default_mmap_threshold" != "x" ]; then
105                 echo "malloc-CPPFLAGS=-DDEFAULT_MMAP_THRESHOLD=\"(${default_mmap_threshold})\"" >configparms
106         fi
107 # override this function to avoid the autoconf/automake/aclocal/autoheader
108 # calls for now
109 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
110 # version check and doesn't really help with anything
111         if [ -z "`which rpcgen`" ]; then
112                 echo "rpcgen not found.  Install glibc-devel."
113                 exit 1
114         fi
115         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
116         CPPFLAGS="" oe_runconf
117 }
118
119 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
120           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
121           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
122
123 do_compile () {
124         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
125         unset LDFLAGS
126         base_do_compile
127         (
128                 cd ${S}/sunrpc/rpcsvc
129                 for r in ${rpcsvc}; do
130                         h=`echo $r|sed -e's,\.x$,.h,'`
131                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
132                 done
133         )
134 }
135
136 require glibc-stage.inc
137
138 require glibc-package.inc