netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / glib-2.0 / glib-2.0_2.23.6.bb
1 DESCRIPTION = "GLib is a general-purpose utility library, \
2 which provides many useful data types, macros, \
3 type conversions, string utilities, file utilities, a main \
4 loop abstraction, and so on. It works on many \
5 UNIX-like platforms, Windows, OS/2 and BeOS."
6 LICENSE = "LGPL"
7 SECTION = "libs"
8 PRIORITY = "optional"
9 DEPENDS = "glib-2.0-native gtk-doc virtual/libiconv virtual/libintl zlib"
10 PR = "r2"
11
12 SRC_URI = "\
13   http://ftp.gnome.org/pub/GNOME/sources/glib/2.23/glib-${PV}.tar.bz2;name=archive \
14   file://glibconfig-sysdefs.h \
15   file://configure-libtool.patch;patch=1 \
16   file://g_once_init_enter.patch;patch=1 \
17   file://gatomic-proper-pointer-get-cast.patch;patch=1 \
18 "
19 SRC_URI[archive.md5sum] = "72e6eadc16d7022376ecef12c6fe905e"
20 SRC_URI[archive.sha256sum] = "f91840e27ad4cd48e655a6babed7e2024f86814f94961da88ca2adba447c6e77"
21
22 SRC_URI_append_arm = " file://atomic-thumb.patch;patch=1"
23 SRC_URI_append_armv6 = " file://gatomic_armv6.patch;patch=1"
24 SRC_URI_append_armv7a = " file://gatomic_armv6.patch;patch=1"
25
26 inherit autotools gettext
27
28 S = "${WORKDIR}/glib-${PV}"
29
30 EXTRA_OECONF = "--disable-debug "
31
32 # Add and entry for your favourite arch if your (g)libc has a sane printf
33 EXTRA_OECONF_append_glibc_arm = "  --enable-included-printf=no "
34
35 do_configure_prepend () {
36         install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
37 }
38
39 do_install_append() {
40         sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
41 }
42
43 DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
44                             pkgconfig-native"
45 EXTRA_OECONF_virtclass-native = ""
46
47 do_configure_prepend_virtclass-native() {
48     if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
49                 echo "${TARGET_SYS}-libtool already present"
50     else
51         cp ${STAGING_BINDIR}/${TARGET_SYS}-libtool ${S}
52     fi
53
54 }
55
56 BBCLASSEXTEND = "native"
57
58 PACKAGES =+ "gobject-2.0 gmodule-2.0 gthread-2.0 gio-2.0 glib-2.0-utils "
59 LEAD_SONAME = "libglib-2.0.*"
60 FILES_glib-2.0-utils = "${bindir}/*"
61 FILES_${PN} = "${libdir}/lib*so.* ${libdir}/gio/modules/*.so"
62 FILES_${PN}-dev += "${libdir}/glib-2.0 ${datadir}/glib-2.0 ${libdir}/gio/modules/*.la"
63 FILES_${PN}-dbg += "${libdir}/gio/modules/.debug"
64 FILES_gmodule-2.0 = "${libdir}/libgmodule-2.0.so.*"
65 FILES_gobject-2.0 = "${libdir}/libgobject-2.0.so.*"
66 FILES_gio-2.0 = "${libdir}/libgio-2.0.so.*"
67 FILES_gthread-2.0 = "${libdir}/libgthread-2.0.so.*"
68
69 # Let various glib components end up in glib package
70 # for compatibility (with binary packages from Maemo).
71 FILES_gthread-2.0_chinook-compat = ""
72 FILES_gmodule-2.0_chinook-compat = ""
73 FILES_gobject-2.0_chinook-compat = ""
74 FILES_gio-2.0_chinook-compat = ""