sg3-utils: add newer buildable version
[openembedded.git] / recipes / gcc / gcc-canadian-sdk_4.2.4.bb
1 inherit canadian-sdk
2
3 PR = "${INC_PR}.2"
4
5 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
6
7 PACKAGES = "${PN}"
8
9 require gcc-${PV}.inc
10
11 # Correct gmp / mpfr
12 DEPENDS = "gmp-canadian mpfr-canadian"
13
14 require gcc-configure-canadian-sdk.inc
15 require gcc-package-sdk.inc
16
17 SRC_URI_append = "file://fortran-cross-compile-hack.patch;patch=1 \
18                   file://pr22133-mingw-path-fixup.patch;patch=1 \
19                   file://pr33281-mingw-host-fragment.patch;patch=1 \
20                   file://pr35916-mingw-__USE_MINGW_ACCESS-everywhere.patch;patch=1 \
21                   file://canadian-build-modules-configure.patch;patch=1 \
22 "
23
24 EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
25                 --disable-libgomp --disable-libmudflap \
26                 --with-mpfr=${STAGING_LIBDIR}"