abiword: add 2.8.3
[openembedded.git] / recipes / freeze / freeze.bb
1 # freeze finds all the bitbake files used by the stuff
2 # currently built in ${TMPDIR}/work and writes those
3 # files into frozen-bbfiles.conf, then it writes the
4 # directories containing the files into frozen-packages.conf
5 #
6 # The two files define (just) the BBFILES variable.
7 #
8 # The path names in the BBFILES variable are of the form:
9 #
10 # ${PKGDIR}/packages/directory/bbfile.bb
11 # ${PKGDIR}/packages/directory/*.bb
12 #
13 # as appropriate, directory is the sub-directory of 'packages'.
14 #
15 DESCRIPTION = "Freeze the bitbake files in the build"
16 SECTION = "console/network"
17 PRIORITY = "optional"
18 LICENSE = "MIT"
19 PR = "r1"
20
21 INHIBIT_DEFAULT_DEPS = "1"
22 PATCH_DEPENDS = ""
23 ALLOW_EMPTY = "1"
24 PACKAGES = ""
25
26 SRC_URI = "file://freeze"
27
28 do_configure() {
29 }
30 do_compile() {
31 }
32 do_install() {
33 }
34 do_stage() {
35 }
36
37 do_build[nostamp] = "1"
38 do_build() {
39         # export FROZEN_DIR=<place to write conf files>
40         # export PKGDIR=<location of openembedded package source>
41         # export DISTRO=<distro being frozen>
42         # freeze {directories}
43         set -x
44         if test -d "${PKGDIR}/packages"
45         then
46                 FROZEN_DIR="${FROZEN_DIR}" PKGDIR="${PKGDIR}" DISTRO="${DISTRO}" \
47                         sh "${WORKDIR}/freeze" "${TMPDIR}/work"
48         else
49                 oenote "\$PKGDIR/packages ($PKGDIR/packages) not found"
50                 oefatal "\$PKGDIR must be defined for freeze to work"
51         fi
52         set +x
53 }