u-boot-omap3pandora: Bump SRCREV to version with UBI enabled.
[openembedded.git] / recipes / freesmartphone / pycd_git.bb
1 DESCRIPTION = "Python Clone Factory"
2 AUTHOR = "Jan Luebbe <jluebbe@debian.org>"
3 HOMEPAGE = "http://www.freesmartphone.org"
4 SECTION = "console/network"
5 LICENSE = "GPLv2"
6 SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
7 PV = "0.1+gitr${SRCREV}"
8 PR = "r0"
9
10 SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
11 S = "${WORKDIR}/git/${PN}"
12
13 RDEPENDS_${PN} = "\
14   python-dbus \
15   python-misc \
16   python-pkgutil \
17   python-resource \
18 "
19
20 do_compile() {
21         ${CC} pyc.c -o pyc
22 }
23
24 do_install() {
25         install -d ${D}${bindir}
26         install -m 755 pyc ${D}${bindir}/pyc
27         install -d ${D}${sbindir}
28         install -m 755 pycd.py ${D}${sbindir}/pycd
29         install -d ${D}${sysconfdir}/dbus-1
30         install -m 644 pycd.conf ${D}${sysconfdir}/dbus-1
31 }
32