u-boot-omap3pandora: Bump SRCREV to version with UBI enabled.
[openembedded.git] / recipes / freesmartphone / fso-gpsd_git.bb
1 DESCRIPTION = "freesmartphone.org gpsd compatibility daemon"
2 LICENSE = "GPL"
3 SECTION = "network"
4 DEPENDS = "dbus-glib"
5 SRCREV = "39e810899110a9bb302cf2064e1c0f73541fb4e6"
6 PV = "0.8+gitr${SRCREV}"
7 PR = "r2"
8
9 SRC_URI = "\
10   ${FREESMARTPHONE_GIT}/fso-gpsd.git;protocol=git;branch=master \
11   file://fso-gpsd \
12 "
13 S = "${WORKDIR}/git"
14
15 inherit autotools update-rc.d
16
17 INITSCRIPT_NAME = "fso-gpsd"
18 INITSCRIPT_PARAMS = "defaults 35"
19
20 do_install_append() {
21     install -d ${D}${sysconfdir}/init.d/
22     install -m 0755 ${WORKDIR}/fso-gpsd ${D}${sysconfdir}/init.d/
23 }
24
25 FILES_${PN} += "${sysconfdir}"
26 RDEPENDS_${PN} = "frameworkd"
27 RPROVIDES_${PN} = "gpsd"
28 # Disabled as we always got gpsd but not fso-gpsd in the fso-image. Needs
29 # fixing.
30 #RCONFLICTS_${PN} = "gpsd"