abiword: add 2.8.3
[openembedded.git] / recipes / fltk / fltk2_svn.bb
1 DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
2 HOMEPAGE = "http://www.fltk.org"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "LGPL"
6 DEPENDS = "zlib jpeg libpng libxext libxft xinput"
7
8 SRCREV = "6916"
9 PV = "1.9.9+svnr${SRCPV}"
10 PR = "r1"
11
12 SRC_URI = "\
13   svn://svn.easysw.com/public/fltk/fltk;proto=http;module=trunk \
14   file://fix-it-damnit.patch;patch=1 \
15 "
16 S = "${WORKDIR}/trunk"
17
18 inherit autotools_stage binconfig
19
20 EXTRA_OECONF = "\
21   --enable-shared \
22   --enable-xdbe \
23   --enable-xft \
24   --disable-gl \
25   --x-includes=${STAGING_INCDIR} \
26   --x-libraries=${STAGING_LIBDIR} \
27 "
28
29 do_configure() {
30         autoconf
31         oe_runconf
32 }
33
34 TARGET_CC_ARCH += "-DXFT_MAJOR=2"
35
36 do_install () {
37         sed -i "s|^STRIP.*=.*$|STRIP = ${STRIP}|" makeinclude
38         sed -i "s|^bindir.*=.*$|bindir = ${D}${bindir}|" makeinclude
39         oe_runmake install \
40                 prefix="${D}${prefix}" \
41                 bindir="${D}${bindir}" \
42                 libdir="${D}${libdir}" \
43                 includedir="${D}${includedir}" \
44                 datadir="${STAGING_DATADIR}"
45                 
46         # add missing links
47         ln -sf ./libfltk2.so.2.0 ${D}${libdir}/libfltk2.so.2
48         ln -sf ./libfltk2_images.so.2.0 ${D}${libdir}/libfltk2_images.so.2
49 }
50
51 PACKAGES =+ "${PN}-fluid ${PN}-images"
52 FILES_${PN}-fluid = "${bindir}/fluid2"
53 FILES_${PN} = "${libdir}/lib*.so.*"
54 FILES_${PN}-images = "${libdir}/libfltk2_images*.so*"
55 FILES_${PN}-dev += "${bindir}/fltk2-config"