netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / fltk / efltk_2.0.7.bb
1 DESCRIPTION = "EFLTK is a cross-platform C++ GUI toolkit"
2 HOMEPAGE = "http://equinox-project.org/page/documentation"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "LGPL"
6 DEPENDS = "zlib jpeg libpng libxext libxft"
7 PR = "r0"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/ede/efltk-${PV}.tar.gz \
10            file://fix.void.cast.patch;patch=1"
11 S = "${WORKDIR}/efltk"
12
13 inherit autotools binconfig
14
15 EXTRA_OECONF = "\
16   --enable-shared \
17   --enable-xdbe \
18   --enable-xft \
19   --enable-gl \
20   --disable-mysql \
21   --disable-unixODBC \
22   --x-includes=${STAGING_INCDIR}/freetype2 \
23   --x-libraries=${STAGING_LIBDIR} \
24 "
25
26 # yes, this is nasty, but configure is so broken there is no other way
27 do_configure() {
28         gnu-configize
29         oe_runconf
30         mv -f config.h save
31         autotools_do_configure
32         mv -f save config.h
33 }
34
35 # more nasties
36 do_configure_append() {
37         sed -i s,/usr/include,${STAGING_INCDIR}, makeinclude
38         sed -i s,/usr/include/freetype2,, makeinclude
39         sed -i s,/usr/bin/strip,echo, makeinclude
40         sed -i s,CONFIGDIR,'"${datadir}/ede/"', src/core/Fl_Config.cpp
41 }
42
43 do_stage() {
44     autotools_stage_all
45 }
46
47 do_install () {
48         install -d ${D}${libdir}
49     oe_runmake install prefix="${D}${prefix}" \
50                bindir="${D}${bindir}" \
51                libdir="${D}${libdir}" \
52                includedir="${D}${includedir}" \
53                datadir="${STAGING_DATADIR}"
54 }
55
56 python populate_packages_prepend () {
57         if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
58                 bb.data.setVar('PKG_${PN}', 'libefltk${PV}', d)
59 }
60
61 LEAD_SONAME = "libefltk.so"
62
63 FILES_${PN} += "${libdir}/fltk/*.theme"
64 FILES_${PN}-dbg += "${libdir}/fltk/.debug"