f90b6ee8275352e78ffb530502726ff6060d4688
[openembedded.git] / recipes / flashrom / flashrom_svn.bb
1 DESCRIPTION = "Flashrom is a simple utility for reading/writing BIOS chips"
2 HOMEPAGE = "http://www.coreboot.org/Flashrom"
3 LICENSE = "GPL"
4 DEPENDS = "zlib pciutils"
5
6 PV = "0.0+svnr${SRCPV}"
7 PR = "r0"
8
9 SRC_URI = " \
10         svn://coreboot.org/repos/trunk/util/;module=flashrom \
11         file://makefile-disable-strip.patch;patch=1 \
12         "
13
14 S = "${WORKDIR}/${PN}"
15
16 LDFLAGS += "-lpci -lz"
17
18 do_install () {
19         install -d "${D}${sbindir}"
20         oe_runmake 'PREFIX=${D}/${prefix}' install
21 }