abiword: add 2.8.3
[openembedded.git] / recipes / fbgrab / fbgrab-viewer-native_1.0.bb
1 DESCRIPTION = "Viewer for a network enabled fbgrab"
2 HOMEPAGE = "http://svn.openezx.org/trunk/src/userspace/fbgrab/"
3 LICENSE = "GPL"
4 SECTION = "console/network"
5 DEPENDS = "libpng-native"
6 SRCREV = "1943"
7 PV = "0.0+svn${SRCDATE}"
8 PR = "r30"
9
10 SRC_URI = "svn://svn.openezx.org/trunk/src/userspace;module=fbgrab;proto=http"
11 S = "${WORKDIR}/fbgrab"
12
13 inherit native
14
15 do_compile() {
16         ${CC} ${CFLAGS} ${LDFLAGS} -g -Wall -lpng -lX11 -o fbgrab-viewer fbgrab-viewer.c
17 }
18
19 do_deploy() {
20         install -d ${DEPLOY_DIR_IMAGE}
21         install -m 0755 fbgrab-viewer ${DEPLOY_DIR_IMAGE}/fbgrab-viewer
22 }
23
24 do_stage() {
25     :
26 }
27
28 do_install() {
29     :
30 }
31
32 addtask deploy before do_install after do_compile