19bbd931847c04db2d014ba1bcf93f21ab15a894
[openembedded.git] / recipes / ezx / ezxd_svn.bb
1 DESCRIPTION = "Open implementation of motorola's tapisrv, replaces opentapi"
2 LICENSE = "GPLv2"
3 SECTION = "devel"
4 AUTHOR = "Daniel Ribeiro"
5
6 PV = "0.0+svnr${SRCPV}"
7 PR = "r4"
8
9 SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=ezxd;proto=http \
10            file://ezxd.init \
11           "
12
13 inherit update-rc.d
14
15 INITSCRIPT_NAME = "ezxd"
16 INITSCRIPT_PARAMS = "start 00 S ."
17
18 S = "${WORKDIR}/${PN}"
19
20 CFLAGS_append = " -DDEBUG " 
21
22 TARGET_CC_ARCH += "${LDFLAGS}"
23
24 do_configure() {
25         # Comment out both CC and CROSS definitions
26         sed -i -e 's:^CC.*$:#\0:g' Makefile
27         sed -i -e 's:^CROSS.*$:#\0:g' Makefile
28 }
29
30 fakeroot do_install() {
31         install -d ${D}/dev/input
32         mknod ${D}/dev/input/uinput c 10 223
33
34         install -d ${D}${bindir}
35         install -m 755 ezxd ${D}${bindir}
36
37         install -d ${D}${libdir}/ezxd
38         install -m 755 *.so ${D}${libdir}/ezxd
39
40         install -d ${D}${sysconfdir}/init.d
41         install -m 0600 ezxd.conf ${D}${sysconfdir}/
42         install -m 0755 ${WORKDIR}/ezxd.init ${D}${sysconfdir}/init.d/ezxd
43 }
44
45 FILES_${PN} += "/dev"
46 CONFFILES_${PN} += "${sysconfdir}/ezxd.conf"
47