EFL: move SRCREVs from sane-srcrevs.inc to efl/e17 recipes
[openembedded.git] / recipes / ezx / ezx-gpiotool_svn.bb
1 DESCRIPTION = "Gpiotool can read/write gpio configuration from userspace."
2 SECTION = "devel"
3 LICENSE = "GPL"
4 HOMEPAGE = "http://www.openezx.org"
5 AUTHOR = "Harald Welte"
6 SRCREV = "1877"
7 PV = "${SRCPV}"
8 PR = "r0"
9
10 SRC_URI = "svn://svn.openezx.org/trunk/src/userspace;module=gpiotool;proto=http"
11 S = "${WORKDIR}/gpiotool"
12
13 do_compile() {
14         for i in mmio.c gpiotool.c gpio.c
15         do
16                 ${CC} ${CFLAGS} -c $i
17         done
18         ${CC} ${CFLAGS} -o ezx-gpiotool mmio.o gpiotool.o gpio.o
19 }
20
21 do_stage() {
22         :
23 }
24
25 do_install() {
26         install -d ${D}${sbindir}
27         install -m 0755 ezx-gpiotool ${D}${sbindir}
28 }