netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / e17 / exalt_svn.bb
1 DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
2 HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
3
4 LICENSE = "LGPLv2"
5 DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
6 RDEPENDS = "vpnc wpa-supplicant"
7
8 PV = "0.9+svnr${SRCPV}"
9 SRCREV = "${EFL_SRCREV}"
10
11 inherit e
12
13 EXTRA_OECONF = " \
14 --with-wpa_supplicant=${sbindir}/wpa_supplicant \
15 --with-vpnc=${sbindir}/vpnc \
16 --with-vpnc-disconnect=${sbindir}/vpnc-disconnect \
17 "
18
19 do_install_append() {
20         # install dbus config file
21         install -d ${D}${sysconfdir}/dbus-1/system.d/
22         install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
23
24         # install dbus service file
25         install -d ${D}${datadir}/dbus-1/system-services/       
26         install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
27 }
28
29 FILES_${PN} += "${datadir}/dbus-1"
30