sg3-utils: add newer buildable version
[openembedded.git] / recipes / e17 / entrance_0.9.0.010.bb
1 DESCRIPTION = "Entrance is the Enlightenment login manager"
2 LICENSE = "MIT BSD"
3 # can also use pam and crypt
4 DEPENDS = "evas ecore edje esmart bash keylaunch xserver-common login-manager"
5 RDEPENDS += "glibc-gconv-iso8859-1 entrance-themes"
6 PR = "r2"
7
8 # entrance and estickies were removed in 46590 for rewrite, move back to EFL_SRCREV when they're back
9 SRCREV = "46589"
10
11 inherit e
12
13 SRC_URI += "\
14            file://rebased_config-db.patch;patch=1 \
15            file://allow-missing-xsession.patch;patch=1 \
16            file://run-Xinit.patch;patch=1 \
17            file://fix-auth-mode.patch;patch=1 \
18            file://use-bash.patch;patch=1 \
19            file://Sessions"
20
21 S = "${WORKDIR}/entrance"
22
23 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
24                 --with-xsession=/etc/X11/Xsession \
25                 --with-auth-mode=0"
26
27 FILES_${PN}-dbg += "${libexecdir}/entrance/.debug/*"
28
29 do_configure_prepend() {
30         autopoint
31 }
32
33 do_install_append() {
34         install -d ${D}/etc/X11/Xsession.d
35         install -d ${D}/etc/X11/Sessions
36
37         install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
38
39         install -d ${D}/etc/X11/login-managers/
40         mv ${D}/etc/init.d/entrance ${D}/etc/X11/login-managers/entrance
41 }