disko: update to version 1.7.0
[openembedded.git] / recipes / disko / disko_1.7.0.bb
1 DESCRIPTION = "Disko is an application framework, that can be used to develop GUI applications for embedded devices. It is closely connected to the DirectFB"
2 LICENSE = "LGPL"
3 PR = "r0"
4
5 require disko.inc
6
7 DEPENDS += "taglib directfb virtual/libx11 hal libxv libxxf86vm"
8
9 SRC_URI = "http://www.diskohq.com/repository/ubuntu/pool/${PN}_${PV}.tar.gz \
10            file://mmsfiletransfer.patch \
11           "
12
13 do_compile() {
14     if [ "${SCONS_FIX_ENV}" = "1" ] ; then
15         if grep "toolchain-from-env" ${S}/SConstruct ; then
16             echo "Toolchain overrides already applied"
17         else
18            cat ${STAGING_DATADIR_NATIVE}/scons/toolchain-from-env.SConscript >> ${S}/SConstruct
19         fi
20     fi
21
22     ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} CXX="${CXX}" PREFIX=${prefix} prefix=${prefix} graphics=all || \
23     oefatal "scons build execution failed."
24 }
25
26 SRC_URI[md5sum] = "23162e567fd980c20ba40b574afd9276"
27 SRC_URI[sha256sum] = "9ec9f5c4c03716cc1d24cc8bce252f4d44ce56837e37f1b9cb6ddc44639dedfc"