sg3-utils: add newer buildable version
[openembedded.git] / recipes / cwiid / cwiid_svn.bb
1 DESCRIPTION = "wiimote library + tools"
2 LICENSE = "GPLv2"
3 HOMEPAGE = "http://abstrakraft.org/cwiid/"
4
5 SRCREV = "192"
6 PV = "0.6.00+svnr${SRCPV}"
7
8 inherit autotools
9 inherit distutils-base
10
11 export BUILD_SYS
12 export HOST_SYS
13
14 PARALLEL_MAKE = ""
15
16 SRC_URI = "svn://abstrakraft.org/cwiid/svn/;module=trunk;proto=http"
17 S = "${WORKDIR}/trunk"
18
19 EXTRA_OECONF = "--disable-ldconfig"
20
21 FILES_${PN} += "\
22         ${sysconfdir}/cwiid/ \
23 "
24
25 FILES_${PN}-dbg += "\
26         ${libdir}/cwiid/plugins/.debug \
27 "
28
29 do_configure_append() {
30         find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
31         find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
32 }
33
34