netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / bluez / bluez-utils_3.33.bb
1 require bluez-utils3.inc
2
3 PR = "r3"
4
5 # TI patch landed upstream sometime between 3.35 and 3.36, 
6 # albeit in a somewhat different form
7 SRC_URI += "file://hciattach-ti-bts.patch;patch=1" 
8
9 # see bluez-utils3.inc for the explanation of these option
10 EXTRA_OECONF = " \
11                  --enable-bccmd \
12                  --enable-hid2hci \
13                  --enable-hidd \
14                  --enable-pand \
15                  --enable-dund \
16                  --disable-alsa \ 
17                  --disable-cups \
18                  --enable-glib \
19                  --disable-sdpd \
20                  --enable-network \
21                  --enable-serial \
22                  --enable-input \
23                  --enable-audio \
24                  --enable-echo \
25                  --enable-configfile \
26                  --enable-initscripts \
27                 --enable-test \
28                 --enable-hidd \
29                 --enable-obex \
30                 --enable-pand \
31                 --enable-dund \
32                 --enable-avctrl \
33                 --enable-hid2hci \
34                 --enable-dfutool \
35                 " 
36
37 CONFFILES_${PN} = " \
38                    ${sysconfdir}/bluetooth/hcid.conf \
39                    ${sysconfdir}/default/bluetooth \
40                   "
41
42 CONFFILES_${PN}-compat = " \
43                           ${sysconfdir}/bluetooth/rfcomm.conf \
44                          "
45
46 PACKAGES =+ "bluez-audio"
47
48 FILES_${PN} = " \
49                ${base_sbindir}/hcid \
50                ${libdir}/bluetooth/plugins/*.so \
51                ${sysconfdir}/init.d/bluetooth \
52                ${sysconfdir}/bluetooth/hcid.conf \
53                ${sysconfdir}/default \
54                ${sysconfdir}/dbus-1 \
55                ${base_sbindir}/hciattach \
56               "
57
58 FILES_bluez-audio = " \
59                      ${libdir}/bluetooth/plugins/libaudio.so \
60                      ${libdir}/gstreamer-0.10/*.so \
61                     "
62
63 FILES_${PN}-dbg += " \
64                     ${libdir}/bluetooth/plugins/.debug \
65                     ${libdir}/gstreamer-0.10/.debug \
66                    "
67
68 FILES_${PN}-dev += " \
69                     ${libdir}/bluetooth/plugins/*.la \
70                     ${libdir}/gstreamer-0.10/*.la \
71                    "