Initial import of my local openpandora.oe.git Open Embedded overlay to the GIT server...
[openpandora.oe.git] / packages / pandora-system / pandora-wifi_git.bb
1 DESCRIPTION = "Kernel drivers for the TI1251 WiFi chip found on the Pandora - Connected via SDIO"
2 LICENSE = "GPLv2"
3
4 PR = "r8"
5
6 # Check the include for the source location/GIT SRCREV etc.
7 require pandora-wifi.inc
8
9 do_compile_prepend() {
10         cd ${S}/sta_dk_4_0_4_32/
11 }
12
13 do_install() {
14         cd ${S}/sta_dk_4_0_4_32/
15         mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net
16         cp ${S}/sta_dk_4_0_4_32/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net
17 }