matrix-gui: Bump up SRCREV
[openembedded.git] / classes / scons.bbclass
1 DEPENDS += "python-scons-native"
2
3 EXTRA_OESCONS ?= ""
4
5 export TARGET_LINK_HASH_STYLE
6
7 scons_do_compile() {
8     if [ "${SCONS_FIX_ENV}" = "1" ] ; then
9         if grep "toolchain-from-env" ${S}/SConstruct ; then
10             echo "Toolchain overrides already applied"
11         else
12            cat ${STAGING_DATADIR_NATIVE}/scons/toolchain-from-env.SConscript >> ${S}/SConstruct
13         fi
14     fi
15
16     ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} CXX="${CXX}" PREFIX=${prefix} prefix=${prefix} ${EXTRA_OESCONS} || \
17     oefatal "scons build execution failed."
18 }
19
20 scons_do_install() {
21         install -d ${D}${prefix}
22         ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} prefix=${D}${prefix} install || \
23         oefatal "scons install execution failed."
24 }
25
26 EXPORT_FUNCTIONS do_compile do_install