matrix-gui: Bump up SRCREV
[openembedded.git] / classes / icecc.bbclass
1 # IceCream distributed compiling support
2 #
3 # Stages directories with symlinks from gcc/g++ to icecc, for both
4 # native and cross compilers. Depending on each configure or compile,
5 # the directories are added at the head of the PATH list and ICECC_CXX
6 # and ICEC_CC are set.
7 #
8 # For the cross compiler, creates a tar.gz of our toolchain and sets
9 # ICECC_VERSION accordingly.
10 #
11 #The class now handles all 3 different compile 'stages' (i.e native ,cross-kernel and target) creating the
12 #necessary enviroment tar.gz file to be used by the remote machines.
13 #It also supports meta-toolchain generation
14 #
15 #If ICECC_PATH is not set in local.conf then the class will try to locate it using 'which'
16 #but nothing is sure ;)
17 #
18 #If ICECC_ENV_EXEC is set in local.conf should point to the icecc-create-env script provided by the user
19 #or the default one provided by icecc-create-env.bb  will be used
20 #(NOTE that this is a modified version of the script need it and *not the one that comes with icecc*
21 #
22 #User can specify if specific packages or packages belonging to class should not use icecc to distribute
23 #compile jobs to remote machines, but handled localy, by defining ICECC_USER_CLASS_BL and ICECC_PACKAGE_BL
24 #with the appropriate values in local.conf
25 #########################################################################################
26 #Error checking is kept to minimum so double check any parameters you pass to the class
27 ###########################################################################################
28
29
30 def icc_determine_gcc_version(gcc):
31     """
32     Hack to determine the version of GCC
33
34     'i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5363)'
35     """
36     return os.popen("%s --version" % gcc ).readline().split()[2]
37
38 def create_cross_env(bb,d):
39     """
40     Create a tar.bz2 of the current toolchain
41     """
42     # Constin native-native compilation no environment needed if
43     # host prefix is empty (let us duplicate the query for ease)
44     prefix = bb.data.expand('${HOST_PREFIX}', d)
45     if len(prefix) == 0:
46         return ""
47
48     import tarfile, socket, time
49     ice_dir = bb.data.expand('${STAGING_DIR_NATIVE}${prefix_native}/${BASE_PACKAGE_ARCH}', d)
50     staging_dir = bb.data.expand('${STAGING_DIR_TARGET}', d)
51     prefix  = bb.data.expand('${HOST_PREFIX}' , d)
52     distro  = bb.data.expand('${DISTRO}', d)
53     target_sys = bb.data.expand('${TARGET_SYS}',  d)
54     target_prefix = bb.data.expand('${TARGET_PREFIX}',  d)
55     float   = bb.data.getVar('TARGET_FPU', d) or "hard"
56     name    = socket.gethostname()
57
58     # Stupid check to determine if we have built a libc and a cross
59     # compiler.
60     try:
61         os.stat(os.path.join(staging_dir, 'usr', 'lib', 'libstdc++.so'))
62         os.stat(os.path.join(ice_dir, 'bin', "%s-g++" % target_sys))
63     except: # no cross compiler built yet
64         return ""
65
66     VERSION = icc_determine_gcc_version( os.path.join(ice_dir,"bin","%s-g++" % target_sys) )
67     cross_name = prefix + distro + "-" + target_sys + "-" + float + "-" + VERSION + "-" + name
68     tar_file = os.path.join(ice_dir, 'ice', cross_name + '.tar.gz')
69
70     try:
71         os.stat(tar_file)
72         # tar file already exists
73         return tar_file
74     except: 
75         try:
76             os.makedirs(os.path.join(ice_dir,'ice'))
77         except:
78             # directory already exists, continue
79             pass
80
81
82     #check if user has specified a specific icecc-create-env script
83     #if not use the OE provided one
84     cr_env_script = bb.data.expand('${ICECC_ENV_EXEC}',  d)
85     if cr_env_script == "${ICECC_ENV_EXEC}":
86         cr_env_script = bb.data.expand('${STAGING_DIR}', d)+"/ice/icecc-create-env"
87     #call the modified create-env script
88     result=os.popen("%s %s %s %s %s %s" %(cr_env_script,
89            "--silent",
90            os.path.join(ice_dir, 'bin', "%s-gcc" % target_sys),
91            os.path.join(ice_dir, 'bin', "%s-g++" % target_sys),
92            os.path.join(ice_dir, 'bin', "%s-as" % target_sys),
93            os.path.join(ice_dir,"ice",cross_name) ) )
94     return tar_file
95
96
97 def create_native_env(bb,d):
98     import tarfile, socket, time
99     ice_dir = bb.data.expand('${STAGING_DIR_NATIVE}${prefix_native}/${BASE_PACKAGE_ARCH}', d)
100     prefix  = bb.data.expand('${HOST_PREFIX}' , d)
101     distro  = bb.data.expand('${DISTRO}', d)
102     target_sys = bb.data.expand('${TARGET_SYS}',  d)
103     target_prefix = bb.data.expand('${TARGET_PREFIX}',  d)
104     float   = bb.data.getVar('TARGET_FPU', d) or "hard"
105     name    = socket.gethostname()
106
107     archive_name = "local-host-env" + "-" + name
108     tar_file = os.path.join(ice_dir, 'ice', archive_name + '.tar.gz')
109
110     try:
111         os.stat(tar_file)
112         # tar file already exists
113         return tar_file
114     except: 
115         try:
116             #os.makedirs(os.path.join(ice_dir))
117             os.makedirs(os.path.join(ice_dir,'ice'))
118         except:
119             # directory already exists, continue
120             pass
121
122     #check if user has specified a specific icecc-create-env script
123     #if not use the OE provided one
124     cr_env_script = bb.data.expand('${ICECC_ENV_EXEC}',  d)
125     if cr_env_script == "${ICECC_ENV_EXEC}":
126         cr_env_script = bb.data.expand('${STAGING_DIR}', d)+"/ice/icecc-create-env"
127     result=os.popen("%s %s %s %s %s %s" %(cr_env_script,
128            "--silent",
129            os.popen("%s gcc" % "which").read()[:-1],
130            os.popen("%s g++" % "which").read()[:-1],
131            os.popen("%s as" % "which").read()[:-1],
132            os.path.join(ice_dir,"ice",archive_name) ) )
133     return tar_file
134
135
136 def get_cross_kernel_cc(bb,d):
137     kernel_cc = bb.data.expand('${KERNEL_CC}', d)
138     kernel_cc = kernel_cc.replace('ccache', '').strip()
139     kernel_cc = kernel_cc.split(' ')[0]
140     kernel_cc = kernel_cc.strip()
141     return kernel_cc
142
143
144 def create_cross_kernel_env(bb,d):
145     import tarfile, socket, time
146     ice_dir = bb.data.expand('${STAGING_DIR_NATIVE}${prefix_native}/${BASE_PACKAGE_ARCH}', d)
147     prefix  = bb.data.expand('${HOST_PREFIX}' , d)
148     distro  = bb.data.expand('${DISTRO}', d)
149     target_sys = bb.data.expand('${TARGET_SYS}',  d)
150     target_prefix = bb.data.expand('${TARGET_PREFIX}',  d)
151     float   = bb.data.getVar('TARGET_FPU', d) or "hard"
152     name    = socket.gethostname()
153     kernel_cc = get_cross_kernel_cc(bb, d)
154
155     # Stupid check to determine if we have built a libc and a cross
156     # compiler.
157     try:
158         os.stat(os.path.join(ice_dir, 'bin', kernel_cc))
159     except: # no cross compiler built yet
160         return ""
161
162     VERSION = icc_determine_gcc_version( os.path.join(ice_dir,"bin",kernel_cc) )
163     cross_name = prefix + distro + "-kernel-" + target_sys + "-" + float + "-" + VERSION + "-" + name
164     tar_file = os.path.join(ice_dir, 'ice', cross_name + '.tar.gz')
165
166     try:
167         os.stat(tar_file)
168         # tar file already exists
169         return tar_file
170     except: 
171         try:
172             os.makedirs(os.path.join(ice_dir,'ice'))
173         except:
174             # directory already exists, continue
175             pass
176
177
178     #check if user has specified a specific icecc-create-env script
179     #if not use the OE provided one
180     cr_env_script = bb.data.getVar('ICECC_ENV_EXEC',  d) or  bb.data.expand('${STAGING_DIR}', d)+"/ice/icecc-create-env"
181     result=os.popen("%s %s %s %s %s %s" %(cr_env_script,
182            "--silent",
183            os.path.join(ice_dir, 'bin', kernel_cc),
184            os.path.join(ice_dir, 'bin', "%s-g++" % target_sys),
185            os.path.join(ice_dir, 'bin', "%s-as" % target_sys),
186            os.path.join(ice_dir, "ice", cross_name) ) )
187     return tar_file
188
189
190 def create_env(bb,d):
191
192         #return create_cross_kernel_env(bb,d) 
193
194         if bb.data.inherits_class("native", d):
195           return create_native_env(bb,d)
196         elif bb.data.inherits_class("kernel", d):
197           return create_cross_kernel_env(bb,d)
198         elif bb.data.inherits_class("cross", d):
199           return create_native_env(bb,d)
200         elif bb.data.inherits_class("sdk", d):
201           return create_native_env(bb,d)
202         else:  
203           return create_cross_env(bb,d)
204
205
206 def create_path(compilers, type, bb, d):
207     """
208     Create Symlinks for the icecc in the staging directory
209     """
210     staging = os.path.join(bb.data.expand('${STAGING_DIR}', d), "ice", type)
211
212     #check if the icecc path is set by the user
213     icecc   = bb.data.getVar('ICECC_PATH', d) or os.popen("%s icecc" % "which").read()[:-1]
214
215     # Create the dir if necessary
216     try:
217         os.stat(staging)
218     except:
219         os.makedirs(staging)
220
221     for compiler in compilers:
222         gcc_path = os.path.join(staging, compiler)
223         try:
224             os.stat(gcc_path)
225         except:
226             os.symlink(icecc, gcc_path)
227
228     return staging + ":"
229
230
231 def use_icc_version(bb,d):
232       icecc_ver = "yes"
233       system_class_blacklist = [ "none" ] 
234
235       for black in system_class_blacklist:
236            if bb.data.inherits_class(black, d):
237               icecc_ver = "no"
238
239       user_class_blacklist =  bb.data.getVar('ICECC_USER_CLASS_BL', d) or "none"
240       user_class_blacklist = user_class_blacklist.split()
241
242       for black in user_class_blacklist:
243            if bb.data.inherits_class(black, d):
244               icecc_ver = "no"
245
246       return icecc_ver
247
248
249 def icc_path(bb,d):
250     package_tmp = bb.data.expand('${PN}', d)
251
252     #"system" package blacklist contains a list of packages that can not distribute compile tasks
253     #for one reason or the other
254     system_package_blacklist = [ "uclibc", "glibc", "gcc", "bind", "u-boot", "dhcp-forwarder", "enchant", "connman" ]
255     user_package_blacklist = (bb.data.getVar('ICECC_USER_PACKAGE_BL', d) or "").split()
256     package_blacklist = system_package_blacklist + user_package_blacklist
257
258     for black in package_blacklist:
259         if black in package_tmp:
260             bb.note(package_tmp, ' found in blacklist, disable icecc')
261             fallback_parallel = bb.data.getVar('ICECC_FALLBACK_PARALLEL', d) or ""
262             bb.data.setVar("PARALLEL_MAKE", fallback_parallel, d)
263             return ""
264
265     prefix = bb.data.expand('${HOST_PREFIX}', d)
266
267     if bb.data.inherits_class("cross", d):
268         return create_path( ["gcc", "g++"], "native", bb, d)
269
270     elif bb.data.inherits_class("native", d):
271         return create_path( ["gcc", "g++"], "native", bb, d)
272
273     elif bb.data.inherits_class("kernel", d):
274         return create_path( [get_cross_kernel_cc(bb,d), ], "cross-kernel", bb, d)
275
276     elif len(prefix) == 0:
277         return create_path( ["gcc", "g++"], "native", bb, d)
278
279     else:
280         return create_path( [prefix+"gcc", prefix+"g++"], "cross", bb, d)      
281
282
283 def icc_version(bb,d):
284     return create_env(bb,d)
285
286
287 def check_for_kernel(bb,d):     
288     if  bb.data.inherits_class("kernel", d):
289          return "yes"
290     return "no"
291
292
293 set_icecc_env() {
294     ICE_PATH=${@icc_path(bb,d)}
295     if test x${ICE_PATH} != x; then
296         export PATH=${ICE_PATH}$PATH
297         export CCACHE_PATH=$PATH
298         #check if we are building a kernel and select gcc-cross-kernel
299         if [ "${@check_for_kernel(bb,d)}" = "yes" ]; then
300             export ICECC_CC="${@get_cross_kernel_cc(bb,d)}"
301             export ICECC_CXX="${HOST_PREFIX}g++"
302         else
303             export ICECC_CC="${HOST_PREFIX}gcc"
304             export ICECC_CXX="${HOST_PREFIX}g++"
305         fi
306
307         if [ "${@use_icc_version(bb,d)}" = "yes" ]; then
308             export ICECC_VERSION="${@icc_version(bb,d)}"
309         else
310             export -n ICECC_VERSION
311         fi
312         oenote "set the icecream environment variables: PATH=$PATH, CCACHE_PATH=$CCACHE_PATH, ICECC_CC=$ICECC_CC, ICECC_CXX=$ICECC_CXX, ICECC_VERSION=$ICECC_VERSION"
313     fi
314 }
315
316 do_configure_prepend() {
317     set_icecc_env
318 }
319
320 do_compile_prepend() {
321     set_icecc_env
322 }
323
324 do_install_prepend() {
325     set_icecc_env
326 }